Notification

Icon
Error

Deployment Java - Try to deploy Java failed

Posted: Friday, May 17, 2019 11:08:03 AM(UTC)
cstoop

cstoop

Member Original PosterPosts: 2
0
Like
After hours of spending to try install Java and copy the files to c:\program files (x86) the exclusion files and the java.seurity file to c:\windows\sun\java\deployment, asking for help.
I have downloaded and edit a package from this forum and have added 2 steps. De installation of java 8.u144 is working fine but the last 2 steps failing. The 2 steps are copying files to the client that Java needs. 1 is voor the exclusion list and the other for security settings in the program files folder \java.

I have tried this as a step:
cmd.exe /c xcopy.exe /Y /I {packageshare}\Java\Sun\Java\Deployment\*.* C:\windows\Sun\Java\Deployment\
The security settings are fine, folder to copy is done by a user with sufficient rights. When i start above in a run command locally it copies the files, but thru lansweeper not. I have also tried to in stead of package share the real name: \\server\folder

Because this failed i have put this line in a batch file and then in Lansweeper execute a script and the path to the batchfile. This is also not working: return -62 last step 11


Why is this working locally on the client but not thru lansweeper what is wrong...
Esben.D
#1Esben.D Member Administration Posts: 1,877  
posted: 5/22/2019 9:18:24 AM(UTC)
If it works through CMD then it should work with Lansweeper too. An alternative is to put to put it all in a script that calls the installer.
mcoleman
#2mcoleman Member Posts: 6  
posted: 5/23/2019 1:37:30 PM(UTC)
Our Java deployment script just does this

copy \\server\share\OracleJRE1.8\deployment.properties C:\Windows\Sun\Java\Deployment

and

copy \\server\share\OracleJRE1.8\exception.sites c:\Windows\Sun\Java\Deployment

mlachance
#3mlachance Member Posts: 12  
posted: 5/23/2019 4:46:38 PM(UTC)
Originally Posted by: mcoleman Go to Quoted Post
Our Java deployment script just does this

copy \\server\share\OracleJRE1.8\deployment.properties C:\Windows\Sun\Java\Deployment

and

copy \\server\share\OracleJRE1.8\exception.sites c:\Windows\Sun\Java\Deployment



Try adding /s to your command line:
cmd.exe /c xcopy.exe /Y /i /s {PackageShare}\Java\Sun\Java\Deployment\*.* "C:\Windows\Sun\Java\Deployment\"

Also, verify your path to {PackageShare}\Java\... is correct.

cmd.exe /c xcopy.exe /Y /i /s is my goto for when copying files. Works everytime.

Active Discussions

Lansweeper Notebooks report
by  Martin Izquierdo   Go to last post Go to first unread
Last post: Today at 4:08:32 PM(UTC)
Lansweeper Unauthorized Administrators by OU
by  Craig Fair  
Go to last post Go to first unread
Last post: Yesterday at 8:05:04 PM(UTC)
Lansweeper Waiting reboot status
by  RJJJR   Go to last post Go to first unread
Last post: Yesterday at 7:01:42 PM(UTC)
Lansweeper reboot required or awaiting reboot report
by  RJJJR  
Go to last post Go to first unread
Last post: Yesterday at 6:58:36 PM(UTC)
Lansweeper Report 32 or 64bit software
by  Esben.D   Go to last post Go to first unread
Last post: Yesterday at 12:21:46 PM(UTC)
Lansweeper Report Needed of just DEFAULT GROUP assets
by  SHib11  
Go to last post Go to first unread
Last post: 10/15/2019 2:57:23 PM(UTC)
Lansweeper No longer shows up-to-date with new OS version
by  ICT Support  
Go to last post Go to first unread
Last post: 10/15/2019 11:29:10 AM(UTC)