Notification

Icon
Error

Jelly
#0Jelly Member Posts: 7  
posted: 5/17/2019 12:09:20 AM(UTC)
Originally Posted by: smozie Go to Quoted Post
I am trying to write a report to find assets within our US domain, that are tied to the tblADUsers.Department %IT% and do no have versions 6.0.0 or 6.0.1 of Traps on their system. I run the code below and what I get back is a bit of a mess, looking for help.

Code:

Select Top 100000 tblAssets.AssetID,
  tblAssets.Domain,
  tblAssets.Username,
  tblADusers.Firstname,
  tblADusers.Lastname,
   tblADusers.Department
From tblAssets
  Inner Join tsysIPLocations On tsysIPLocations.LocationID =
    tblAssets.LocationID
  Left Join tblADusers On tblADusers.Username = tblAssets.Username And
    tblADusers.Userdomain = tblAssets.Userdomain
  Inner Join tblSoftware On tblAssets.AssetID = tblSoftware.AssetID
  Inner Join tblSoftwareUni On tblSoftware.softID = tblSoftwareUni.SoftID
Where tblSoftwareUni.softwareName Like '%traps%' And tblSoftware.softwareVersion Not
  Like '6.0.0%' And tblSoftware.softwareVersion Not Like '6.0.1%' AND tblADusers.Userdomain Like '%US%' And tblADusers.Department Like '%IT%'
Order By tblAssets.AssetName





Try this changed your left join and a few other things. Personally I wouldn't post with the software names/versions/domain/department info not anonymized.
Code:

Select Top 100000 tblAssets.AssetID,
  tblAssets.Domain,
  tblAssets.Username,
  tblADusers.Firstname,
  tblADusers.Lastname,
   tblADusers.Department
From tblAssets
  Inner Join tsysIPLocations On tsysIPLocations.LocationID = tblAssets.LocationID
  Left Join tblADusers On tblAssets.Username = tblADusers.Username 
  Inner Join tblSoftware On tblAssets.AssetID = tblSoftware.AssetID
  Inner Join tblSoftwareUni On tblSoftware.softID = tblSoftwareUni.SoftID
Where tblSoftwareUni.softwareName Like '%traps%' 
And tblSoftware.softwareVersion Not Like '6.0.0%' 
And tblSoftware.softwareVersion Not Like '6.0.1%' 
AND tblAssets.Domain = 'us'
And tblADusers.Department Like '%IT%'
Order By tblAssets.AssetName



Active Discussions

Lansweeper TPM scanning
by  gene@sca   Go to last post Go to first unread
Last post: Yesterday at 10:40:24 PM(UTC)
Lansweeper Bulk AssetLock set
by  tcooper  
Go to last post Go to first unread
Last post: Yesterday at 6:24:15 PM(UTC)
Lansweeper Set AssetType based on Model?
by  tcooper   Go to last post Go to first unread
Last post: Yesterday at 6:16:57 PM(UTC)
Lansweeper Public IP Address
by  David Goodwin  
Go to last post Go to first unread
Last post: Yesterday at 4:57:14 PM(UTC)
Lansweeper Exchange Scan in v7 and DAG
by  Peter.Riederer   Go to last post Go to first unread
Last post: Yesterday at 8:42:48 AM(UTC)
Lansweeper Asset Scanning - Change Types
by  DNuhija  
Go to last post Go to first unread
Last post: 12/12/2019 5:40:47 PM(UTC)
Lansweeper Plundervolt
by  NWSF   Go to last post Go to first unread
Last post: 12/12/2019 5:10:14 PM(UTC)
Lansweeper MSI Package
by  Stefano Magri  
Go to last post Go to first unread
Last post: 12/12/2019 3:34:16 PM(UTC)