Notification

Icon
Error

One deployment = 1 registry new entry ? - For each deployment made by Lansweeper we found a new registry key as log

Posted: Wednesday, May 15, 2019 2:07:51 PM(UTC)
FOVISI

FOVISI

Member Original PosterPosts: 3
0
Like
This issue has been solved! Click here to view the solution
Hi there,

We saw that each time we made a deployment with Lansweeper, a new key in the registry is added.
Is it normal ?
It's not good for our PCs performance :(

See screenshot
[img=https://ibb.co/bNjFRkT]WTF[/img]
https://ibb.co/bNjFRkT
CyberCitizen
#1CyberCitizen Member Posts: 186  
posted: 5/17/2019 1:05:11 AM(UTC)
That is so it can relate to the Task Scheduler process for the install and then the reporting back to Lansweeper. They are a small amount of text and shouldn't have a huge performance issue on machines, however I do agree that Lansweeper should clear this up once completed.
CyberCitizen
#2CyberCitizen Member Posts: 186  
posted: 5/17/2019 1:32:57 AM(UTC)
Actually, I believe Lansweeper does clean this up, as I have looked at my test deployment machine over 200 deployments to it, and only has maybe 30 entries in that registry location.
Susan.A
#3Susan.A Member Administration Posts: 1,535  
posted: 6/1/2019 11:26:26 AM(UTC)
Registry keys are created for deployments on your client machines because that's where we store the deployment steps executed by the deployment task. As indicated by CyberCitizen, this shouldn't affect your machines' performance and we do clean these up. A change was implemented for this back in Lansweeper 6.0.110. I've pasted the relevant changelog entry below.

Changed: #434948 When deploying to a Windows computer, registry keys related to previous deployments are now deleted, if they are older than 30 days

Active Discussions

Lansweeper Copying computer names that include a hyphen
by  CyberCitizen  
Go to last post Go to first unread
Last post: Today at 4:30:25 AM(UTC)
Installer LsAgent for Windows
by  bbeavis   Go to last post Go to first unread
Last post: Yesterday at 10:17:18 PM(UTC)
Lansweeper lansweeper 7
by  Esben.D  
Go to last post Go to first unread
Last post: Yesterday at 4:27:34 PM(UTC)
Lansweeper dotNET framework 3.5 deployment
by  Ramezi   Go to last post Go to first unread
Last post: Yesterday at 3:49:15 PM(UTC)
Lansweeper InTune Scanning not showing all devices
by  TBRIT  
Go to last post Go to first unread
Last post: Yesterday at 3:05:17 PM(UTC)
Lansweeper lsAgent MSI installer
by  Sandro   Go to last post Go to first unread
Last post: Yesterday at 10:52:39 AM(UTC)
Lansweeper report of workstation with 2nd screen
by  Esben.D  
Go to last post Go to first unread
Last post: 7/12/2019 12:43:16 PM(UTC)