Notification

Icon
Error

Top 5 CPU utilization

Posted: Tuesday, April 23, 2019 10:17:49 AM(UTC)
Esben.D

Esben.D

Member Administration Original PosterPosts: 1,834
0
Like
This report is also highlighted in this blog post.

The report gives a top 5 of assets which have the highest average CPU usage as scanned by the performance counters. Please note that performance counter scanning has to be manually enabled. Additionally, this feature is only available in Lansweeper 7.1 or higher.

Code:
Select Top 5 tblAssets.AssetID,
  tblAssets.AssetName,
  Cast(Avg(tblPerformanceCountersScanMetric.Value) As int) As
  [Average CPU usage in %],
  Coalesce(tsysOS.Image, tsysAssetTypes.AssetTypeIcon10) As icon,
  Max(tblPerformanceCountersScan.ScanDateTime) As [Last scan]
From tblAssets
  Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
  Inner Join tsysAssetTypes On tsysAssetTypes.AssetType = tblAssets.Assettype
  Inner Join tblPerformanceCountersScan On tblAssets.AssetID =
    tblPerformanceCountersScan.AssetId
  Inner Join tblPerformanceCountersScanMetric On tblPerformanceCountersScan.Id =
    tblPerformanceCountersScanMetric.PerformanceCountersScanId
  Left Join tblPerformanceCountersScanMetricIdentifier On
    tblPerformanceCountersScanMetricIdentifier.Id =
    tblPerformanceCountersScanMetric.PerformanceCountersScanMetricIdentifierId
  Inner Join tsysPerformanceCounterMetric On tsysPerformanceCounterMetric.Id =
    tblPerformanceCountersScanMetric.Metric
  Left Join tsysOS On tsysOS.OScode = tblAssets.OScode
Where tsysPerformanceCounterMetric.[Group] = 'CPU' And tblAssetCustom.State = 1
Group By tblAssets.AssetID,
  tblAssets.AssetName,
  Coalesce(tsysOS.Image, tsysAssetTypes.AssetTypeIcon10)
Having Max(tblPerformanceCountersScan.ScanDateTime) > GetDate() - 7
Order By [Average CPU usage in %] Desc
no1welshboyo
#1no1welshboyo Member Posts: 2  
posted: 4/24/2019 10:04:47 AM(UTC)
Hi,

Whenever I try and create this report I get the following error message

"In aggregate and grouping expressions, the ORDER BY clause can contain only aggregate functions and grouping expressions"

Any ideas what is wrong?

Many thanks
Esben.D
#2Esben.D Member Administration Original PosterPosts: 1,834  
posted: 4/24/2019 10:43:04 AM(UTC)
It was a typo at the end of the report. I've updated the original.
no1welshboyo
#3no1welshboyo Member Posts: 2  
posted: 4/24/2019 10:52:35 AM(UTC)
Thats great that works now thank you!

Active Discussions

Lansweeper Asset Value Report
by  RC62N   Go to last post Go to first unread
Last post: 9/20/2019 7:12:29 PM(UTC)
Lansweeper Display Hyper-V Guest User report
by  GlenTB  
Go to last post Go to first unread
Last post: 9/20/2019 2:26:15 PM(UTC)
Report Center Windows Defender Antivirus Broken Scan Audit
by  Esben.D   Go to last post Go to first unread
Last post: 9/20/2019 12:18:02 PM(UTC)
Lansweeper Reports are empty
by  Mendoza  
Go to last post Go to first unread
Last post: 9/20/2019 11:12:18 AM(UTC)
Lansweeper Custom Helpdesk Report
by  StevoCamaro   Go to last post Go to first unread
Last post: 9/19/2019 11:13:05 PM(UTC)
Lansweeper Windows 7 EOL
by  RC62N  
Go to last post Go to first unread
Last post: 9/19/2019 4:42:11 PM(UTC)
Lansweeper Drive Encryption statuses
by  DFox   Go to last post Go to first unread
Last post: 9/19/2019 12:54:06 PM(UTC)
Lansweeper Patch Tuesday report, last 3 months
by  Esben.D  
Go to last post Go to first unread
Last post: 9/19/2019 10:55:07 AM(UTC)