Notification

Icon
Error

Another AV report request

Posted: Friday, February 26, 2016 8:31:42 PM(UTC)
jmje

jmje

Member Original PosterPosts: 18
0
Like
This issue has been solved! Click here to view the solution
Hi, I've been trying to get a report that will show me if a machine doesn't have the current Symantec Endpoint protection installed. I have it showing me ANY antivirus that is out of date, but that's part of the problem.

I'd like a few reports in the end that give me these specifics :

1) Symantec Endpoint Protection, out of date or disabled.
2) More than 1 Antivirus product installed.
3) No Antivirus installed. (Already have, and it appears to work fine.)

I work in a multi-domain environment, so if I can get the following in the report, that'd be great.

1) Asset name
2) domain
3) IP Address
4) Antivirus enabled/disabled, version of signature file if out of date, etc... as appropriate for the 3 reports above.

Thanks in advance. I'm apparently pretty bad at sql queries, and we're a small IT shop without SQL programmers, so it's been hard going.

J
ict-user
#1ict-user Member Posts: 38  
posted: 2/29/2016 9:59:32 AM(UTC)
1:
Select Top 1000000 tblAssets.AssetID,
tblAssets.AssetName,
tsysAssetTypes.AssetTypename,
tsysAssetTypes.AssetTypeIcon10 As icon,
tblAssets.IPAddress,
tblAssets.Lastseen,
tblAssets.Lasttried,
tblAntivirus.DisplayName As Antivirus
From tblAssets
Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
Inner Join tsysAssetTypes On tsysAssetTypes.AssetType = tblAssets.Assettype
Inner Join tblAntivirus On tblAssets.AssetID = tblAntivirus.AssetID
Where tblAntivirus.DisplayName Like '%Symantec%' And tblAssetCustom.State = 1
And tblAntivirus.productUpToDate = 0
Order By tblAssets.AssetName

jmje
#2jmje Member Original PosterPosts: 18  
posted: 2/29/2016 2:08:57 PM(UTC)
Thanks much.

Is that "out of date" OR "disabled", though?
Looking at the results it's showing me assets with AV enabled that are out of date, but not devices that have AV disabled. Does this need to be 2 separate reports?

Thanks again!

J
ict-user
#3ict-user Member Posts: 38  
posted: 3/1/2016 1:47:04 PM(UTC)
out of date
jmje
#4jmje Member Original PosterPosts: 18  
posted: 3/1/2016 2:59:24 PM(UTC)
Ok. Thank you. :)
Unhappymeal
#5Unhappymeal Member Posts: 1  
posted: 5/19/2017 5:23:52 PM(UTC)
Is there a way to add what the out of date def file is? i found the reg key and value.

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Symantec\Symantec Endpoint Protection\CurrentVersion\public-opstate]
"LatestVirusDefsDate"="2017-05-19"

Active Discussions

Lansweeper Microsoft Office Products
by  RChapman   Go to last post Go to first unread
Last post: Today at 9:32:29 PM(UTC)
Lansweeper Report to report systems that did not recieve the package
by  wgates10   Go to last post Go to first unread
Last post: 6/15/2018 3:59:12 PM(UTC)
Lansweeper Antivius Pattern Date Older than x Days
by  spencerwaller  
Go to last post Go to first unread
Last post: 6/15/2018 2:45:40 PM(UTC)
Lansweeper Linux machines with Network Adapter Names
by  JTempleton   Go to last post Go to first unread
Last post: 6/15/2018 1:54:08 PM(UTC)
Lansweeper AD users and computers report
by  Charles.X  
Go to last post Go to first unread
Last post: 6/15/2018 9:41:21 AM(UTC)
Lansweeper Report to show all devices with vPro
by  Terry Jamro   Go to last post Go to first unread
Last post: 6/14/2018 2:16:51 PM(UTC)