Notification

Icon
Error

Forecast.io displays, but issues...

Posted: Monday, January 13, 2014 4:41:33 PM(UTC)
dteague

dteague

Member Original PosterPosts: 79
0
Like
After seeing someone wanting the weather, I already was using a RSS feed from a difference source for weather, but forgot I could have an iframe to do it. When I set it up as http://forecast.io/embed...#00aaff&font=Georgia as the URL, it displays, but then under it, I get a message that The Contend cannot be displayed in a frame.

Ideas to why?
dteague attached the following image(s):
forecast-io.gif
Lansweeper
#1Lansweeper Member Posts: 13,442  
posted: 1/14/2014 12:15:19 PM(UTC)
The "error message" is the background image of the widget which is shown if nothing is loaded.

Most likely the weather content is made transparent which makes the error image visible.
dteague
#2dteague Member Original PosterPosts: 79  
posted: 1/14/2014 4:02:47 PM(UTC)
Lansweeper wrote:
The "error message" is the background image of the widget which is shown if nothing is loaded.

Most likely the weather content is made transparent which makes the error image visible.

Is there anything I can do to not get the "error message"? Or just not use this weather site?
Lansweeper
#3Lansweeper Member Posts: 13,442  
posted: 1/14/2014 4:28:08 PM(UTC)
dteague
#4dteague Member Original PosterPosts: 79  
posted: 1/14/2014 10:53:51 PM(UTC)
Lansweeper wrote:

Well, I just made a copy of the iframe widget and removed the error graphic reference since everything was there.

Thanks
Jono
#5Jono Member Posts: 111  
posted: 1/15/2014 6:49:34 PM(UTC)
That's a great idea! Thanks!
Lansweeper
#6Lansweeper Member Posts: 13,442  
posted: 1/15/2014 6:56:07 PM(UTC)
dteague wrote:

Well, I just made a copy of the iframe widget and removed the error graphic reference since everything was there.

That's even better!
JTempleton
#7JTempleton Member Posts: 46  
posted: 10/2/2014 6:20:44 PM(UTC)
Sorry to bring up an old post, but what did you do to remove the error graphic? I tried to follow the link and figure it out, but I couldn't get it to work.
dteague
#8dteague Member Original PosterPosts: 79  
posted: 10/3/2014 6:42:51 PM(UTC)
JTempleton wrote:
Sorry to bring up an old post, but what did you do to remove the error graphic? I tried to follow the link and figure it out, but I couldn't get it to work.


Copy Iframe.* from Widgets to Widgetscustom naming them Iframe1.*

in Iframe1.aspx, at line 28, remove background-image: url("<%=ResolveUrl("~/")%>images/iframeErr.png");

JTempleton
#9JTempleton Member Posts: 46  
posted: 10/3/2014 6:44:29 PM(UTC)
Thanks! That is very helpful!
LJayP
#10LJayP Member Premium Users Posts: 15  
posted: 6/15/2015 2:51:13 PM(UTC)
Thanks for sharing this, was trying to get the error message to hide. Very useful thanks
KadeBarton
#11KadeBarton Member Posts: 1  
posted: 6/7/2016 2:37:55 PM(UTC)
I was able to get this fixed by just going in and typing editing the custom widget's .aspx file to show the following:
Background: none;

I however am brand new to LanSweeper and am wondering where in the .aspx I can make the URL go to forcast.io's information and have it be a regular widget as opposed to having to input the URL for each user who wants that custom widget.

Sorry to bring up an old post, but this one seems to be pretty helpful.

Active Discussions

Lansweeper End of Life Asset Report
by  Hendrik.VE   Go to last post Go to first unread
Last post: Today at 2:18:23 PM(UTC)
Lansweeper Translation settings not saved
by  Brandon  
Go to last post Go to first unread
Last post: Yesterday at 2:10:22 PM(UTC)
Lansweeper Combobox translation
by  sneagele   Go to last post Go to first unread
Last post: Yesterday at 2:03:45 PM(UTC)
Lansweeper Freelance for Lansweeper Deploy?
by  Brandon  
Go to last post Go to first unread
Last post: 5/7/2021 6:32:21 PM(UTC)
Lansweeper Installation issues
by  Richie_Rich   Go to last post Go to first unread
Last post: 5/6/2021 11:29:09 PM(UTC)
Lansweeper Cloud relay data stored time
by  Richie_Rich  
Go to last post Go to first unread
Last post: 5/6/2021 11:14:42 PM(UTC)
Lansweeper Custom attributes from AD
by  dhoward   Go to last post Go to first unread
Last post: 5/6/2021 11:10:45 PM(UTC)
Lansweeper User View Customization
by  DarkOne77  
Go to last post Go to first unread
Last post: 5/6/2021 10:50:30 PM(UTC)