Notification

Icon
Error

.NET Runtime 2.0 Error - EventType clr20r3

Posted: Thursday, June 5, 2008 12:31:27 PM(UTC)
workshop

workshop

Member Original PosterPosts: 20
0
Like
Hi Lansweeper is working well in our organisation, however almost daily the server experiences the same problem.

The queue starts to build and stops processing then eventually we get

.NET Runtime 2.0 EEvent Type: Error

Event Source: .NET Runtime 2.0 Error Reporting
Event Category: None
Event ID: 5000
Date: 05/06/2008
Time: 10:03:42
User: N/A
Computer: %MYSERVERNAME%
Description:
EventType clr20r3, P1 lansweeper30.exe, P2 3.1.3028.22480, P3 4805f4fe, P4 system, P5 2.0.0.0, P6 471ebf0d, P7 2652, P8 272, P9 system.net.httplistenerexception, P10 NIL.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 63 00 6c 00 72 00 32 00 c.l.r.2.
0008: 30 00 72 00 33 00 2c 00 0.r.3.,.
0010: 20 00 6c 00 61 00 6e 00 .l.a.n.
0018: 73 00 77 00 65 00 65 00 s.w.e.e.
0020: 70 00 65 00 72 00 33 00 p.e.r.3.
0028: 30 00 2e 00 65 00 78 00 0...e.x.
0030: 65 00 2c 00 20 00 33 00 e.,. .3.
0038: 2e 00 31 00 2e 00 33 00 ..1...3.
0040: 30 00 32 00 38 00 2e 00 0.2.8...
0048: 32 00 32 00 34 00 38 00 2.2.4.8.
0050: 30 00 2c 00 20 00 34 00 0.,. .4.
0058: 38 00 30 00 35 00 66 00 8.0.5.f.
0060: 34 00 66 00 65 00 2c 00 4.f.e.,.
0068: 20 00 73 00 79 00 73 00 .s.y.s.
0070: 74 00 65 00 6d 00 2c 00 t.e.m.,.
0078: 20 00 32 00 2e 00 30 00 .2...0.
0080: 2e 00 30 00 2e 00 30 00 ..0...0.
0088: 2c 00 20 00 34 00 37 00 ,. .4.7.
0090: 31 00 65 00 62 00 66 00 1.e.b.f.
0098: 30 00 64 00 2c 00 20 00 0.d.,. .
00a0: 32 00 36 00 35 00 32 00 2.6.5.2.
00a8: 2c 00 20 00 32 00 37 00 ,. .2.7.
00b0: 32 00 2c 00 20 00 73 00 2.,. .s.
00b8: 79 00 73 00 74 00 65 00 y.s.t.e.
00c0: 6d 00 2e 00 6e 00 65 00 m...n.e.
00c8: 74 00 2e 00 68 00 74 00 t...h.t.
00d0: 74 00 70 00 6c 00 69 00 t.p.l.i.
00d8: 73 00 74 00 65 00 6e 00 s.t.e.n.
00e0: 65 00 72 00 65 00 78 00 e.r.e.x.
00e8: 63 00 65 00 70 00 74 00 c.e.p.t.
00f0: 69 00 6f 00 6e 00 20 00 i.o.n. .
00f8: 4e 00 49 00 4c 00 0d 00 N.I.L...
0100: 0a 00 ..



The error log shows the following several times around the time it crashes (when I say several times I mean hundreds!!!).


05/06/2008 10:03:28
System.Net.HttpListenerException: The specified network name is no longer available
at System.Net.HttpResponseStream.Write(Byte[] buffer, Int32 offset, Int32 size)
at System.IO.StreamWriter.Flush(Boolean flushStream, Boolean flushEncoder)
at System.IO.StreamWriter.Write(Char[] buffer, Int32 index, Int32 count)
at System.IO.TextWriter.WriteLine(String value)
at Lansweeper31.Listen.DoListen()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()

05/06/2008 10:03:28
System.Net.HttpListenerException: The specified network name is no longer available
at System.Net.HttpResponseStream.Write(Byte[] buffer, Int32 offset, Int32 size)
at System.IO.StreamWriter.Flush(Boolean flushStream, Boolean flushEncoder)
at System.IO.StreamWriter.Write(Char[] buffer, Int32 index, Int32 count)
at System.IO.TextWriter.WriteLine(String value)
at Lansweeper31.Listen.DoListen()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()




Any ideas....?

I put a scheduled reboot in every morning to overcome this issue - but it doesn't seem to work.

My theory is perhaps the server gets overloaded with requests - as most people will be logging on in the morning and the login script will be registering the computer and the server can't cope with the requests... Is this possible? Is there a solution...?

Thanks.

workshop
#1workshop Member Original PosterPosts: 20  
posted: 6/9/2008 6:15:01 PM(UTC)
Sorry to bump - but any ideas?
Lansweeper
#2Lansweeper Member Administration Posts: 13,442  
posted: 6/9/2008 6:20:00 PM(UTC)
As far as I can find on msdn : a computer is forcibly closing the connection during the http request.
I will create a test service executable for you to test to solve this problem
workshop
#3workshop Member Original PosterPosts: 20  
posted: 6/18/2008 10:25:42 AM(UTC)
Hi - where can I can the the test service executable?

This is problem is occurring nearly every day and obviously missing lots of machines early in the morning.

Hope you can help.
workshop
#4workshop Member Original PosterPosts: 20  
posted: 7/10/2008 7:58:48 PM(UTC)
Any news on the test service exe you mention?
workshop
#5workshop Member Original PosterPosts: 20  
posted: 7/18/2008 10:46:42 AM(UTC)
For info - I have rebuilt a new server (more powerful) and resinstalled Lansweeper using the installer.

Migrated the database over and yet, still getting this message - usually this happens early in the morning - as I said - almost seems to be because too many machines are trying to connect to LS.

Is there an upper limit? We have about 3000 machines.

I did send you my email address (as requested in your PM) for the test service you mention.

I would love to get this problem sorted as this is a great product that is working really well for us - except this issue.

Hope you can help.
ccdesktop
#6ccdesktop Member Posts: 118  
posted: 10/20/2008 3:26:43 PM(UTC)
I get this similar error quite a lot. Mainly in the morning when most people log on to their workstations.

We have about 3000 users in total and probably about 1500 people are logging on first thing in the morning.

Here is copy of the error event: Any ideas...?

Quote:
Event Type: Error
Event Source: .NET Runtime 2.0 Error Reporting
Event Category: None
Event ID: 5000
Date: 20/10/2008
Time: 09:18:08
User: N/A
Computer: SERVERNAME
Description:
EventType clr20r3, P1 lansweeperservice.exe, P2 3.2.3198.21311, P3 48ea2b63, P4 mscorlib, P5 2.0.0.0, P6 471ebc5b, P7 36a8, P8 8c, P9 system.indexoutofrangeexception, P10 NIL.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 63 00 6c 00 72 00 32 00 c.l.r.2.
0008: 30 00 72 00 33 00 2c 00 0.r.3.,.
0010: 20 00 6c 00 61 00 6e 00 .l.a.n.
0018: 73 00 77 00 65 00 65 00 s.w.e.e.
0020: 70 00 65 00 72 00 73 00 p.e.r.s.
0028: 65 00 72 00 76 00 69 00 e.r.v.i.
0030: 63 00 65 00 2e 00 65 00 c.e...e.
0038: 78 00 65 00 2c 00 20 00 x.e.,. .
0040: 33 00 2e 00 32 00 2e 00 3...2...
0048: 33 00 31 00 39 00 38 00 3.1.9.8.
0050: 2e 00 32 00 31 00 33 00 ..2.1.3.
0058: 31 00 31 00 2c 00 20 00 1.1.,. .
0060: 34 00 38 00 65 00 61 00 4.8.e.a.
0068: 32 00 62 00 36 00 33 00 2.b.6.3.
0070: 2c 00 20 00 6d 00 73 00 ,. .m.s.
0078: 63 00 6f 00 72 00 6c 00 c.o.r.l.
0080: 69 00 62 00 2c 00 20 00 i.b.,. .
0088: 32 00 2e 00 30 00 2e 00 2...0...
0090: 30 00 2e 00 30 00 2c 00 0...0.,.
0098: 20 00 34 00 37 00 31 00 .4.7.1.
00a0: 65 00 62 00 63 00 35 00 e.b.c.5.
00a8: 62 00 2c 00 20 00 33 00 b.,. .3.
00b0: 36 00 61 00 38 00 2c 00 6.a.8.,.
00b8: 20 00 38 00 63 00 2c 00 .8.c.,.
00c0: 20 00 73 00 79 00 73 00 .s.y.s.
00c8: 74 00 65 00 6d 00 2e 00 t.e.m...
00d0: 69 00 6e 00 64 00 65 00 i.n.d.e.
00d8: 78 00 6f 00 75 00 74 00 x.o.u.t.
00e0: 6f 00 66 00 72 00 61 00 o.f.r.a.
00e8: 6e 00 67 00 65 00 65 00 n.g.e.e.
00f0: 78 00 63 00 65 00 70 00 x.c.e.p.
00f8: 74 00 69 00 6f 00 6e 00 t.i.o.n.
0100: 20 00 4e 00 49 00 4c 00 .N.I.L.
0108: 0d 00 0a 00 ....


Lansweeper
#7Lansweeper Member Administration Posts: 13,442  
posted: 10/20/2008 7:13:52 PM(UTC)
Could you try the newly released service please.
ccdesktop
#8ccdesktop Member Posts: 118  
posted: 10/23/2008 2:35:54 PM(UTC)
So far so good with the Update 1.

Has something changed that should have overcome this issue - or is it cooincidence...?

Lansweeper
#9Lansweeper Member Administration Posts: 13,442  
posted: 10/23/2008 6:27:13 PM(UTC)
I believe this was related to the "stay in process" error

Active Discussions

Lansweeper anonymous access for users
by  jbrawley1   Go to last post Go to first unread
Last post: Yesterday at 3:11:11 PM(UTC)
Lansweeper External web access
by  jbrawley1  
Go to last post Go to first unread
Last post: Yesterday at 1:43:10 AM(UTC)
Lansweeper Asset Problem
by  arlan   Go to last post Go to first unread
Last post: 9/21/2018 10:34:25 PM(UTC)
Lansweeper Scanning VMware vCenter
by  mzipperer  
Go to last post Go to first unread
Last post: 9/21/2018 9:52:20 PM(UTC)
Lansweeper Authentication
by  ehbilodeau   Go to last post Go to first unread
Last post: 9/21/2018 9:31:36 PM(UTC)
Lansweeper Cleanup assets inactive in AD (but not disabled
by  rasldasl  
Go to last post Go to first unread
Last post: 9/21/2018 9:29:40 PM(UTC)
Lansweeper LS 7 disable the login page
by  AZHockeyNut   Go to last post Go to first unread
Last post: 9/21/2018 7:46:05 PM(UTC)
Lansweeper Lansweeper Crash
by  abetzold  
Go to last post Go to first unread
Last post: 9/21/2018 7:17:43 PM(UTC)