Lansweeper logo
HomeDownloadBuy NowFeaturesSupportForumBlog
Welcome Guest Search | Active Topics | Log In | Register

Untag as favorite
Connecting to !P_ADD: Failed
Tom
#1 Posted : Monday, December 11, 2006 5:31:50 PM
Rank: Freeware user

Groups: Member
Posts: 1
Iv installed SQL 2005 SP2 on a Longhorn beta server. Created the LS database as per instructions. When i try to logon to th econsole i get:

Code:

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load file or assembly 'DreamweaverCtrls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=836f606ede05d46a' or one of its dependencies. The system cannot find the file specified.

Source Error:


Line 1:  <%@ Page Language="VB" ContentType="text/html" %>
Line 2:  <%@ Register TagPrefix="MM" Namespace="DreamweaverCtrls" Assembly="DreamweaverCtrls,version=1.0.0.0,publicKeyToken=836f606ede05d46a,culture=neutral" %>
Line 3:  <MM:DataSet
Line 4:  runat="Server"


Ive tried registering DreamweaverCtrls but dont think thats the problem.

Ive installed the service which is up and running with credentials of lsuser, lsscanner and administrator but have the following problem when this is executed from a client machine (that is the lsclient)

Quote:

-- LanSweeper Client --

Connecting to IP_ADD: failed



IP_ADD is the ip address of the longhorn server. SQL database is configured with Widnows and SWL authentication, database has full rights for lsuser.
LS config reads as:

Code:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <appSettings>
        <!--   User application and configured property settings go here.-->
        <!--   Example: <add key="settingName" value="settingValue"/> -->
        <add key="ConnectionString" value="integrated security=SSPI;data source=&quot;localhost&quot;;persist security info=False;initial catalog=Lansweeper" />
        <add key="ConcurrentThreads" value="10" />
    </appSettings>
</configuration>


LSWinap config reads:

Code:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <appSettings>
        <!--   User application and configured property settings go here.-->
        <!--   Example: <add key="settingName" value="settingValue"/> -->
        <add key="ConnectionString" value="integrated security=SSPI;data source=&quot;127.0.0.1&quot;;persist security info=False;initial catalog=Lansweeper" />
        <add key="ConcurrentThreads" value="10" />
    </appSettings>
</configuration>


Webconfig:

Code:

<configuration>
    <appSettings>
        <add key="MM_CONNECTION_HANDLER_Lansweeper" value="sqlserver.htm" />
        <add key="MM_CONNECTION_STRING_Lansweeper" value="Persist Security Info=False;Data Source=127.0.0.1;Initial Catalog=Lansweeper;User ID=Isuser;Password=NewPassword1" />
        <add key="MM_CONNECTION_DATABASETYPE_Lansweeper" value="SQLServer" />
        <add key="MM_CONNECTION_SCHEMA_Lansweeper" value="" />
        <add key="MM_CONNECTION_CATALOG_Lansweeper" value="" />
    </appSettings>
</configuration>


The users are on the domain (lsuser/scanner)

I cant find any logs to why its failed but have tried running it as 3 different users all with the same error. Anyone got any ideas?

Thanks
Lansweeper
#2 Posted : Monday, December 11, 2006 6:56:46 PM

Rank: Administration

Groups: Administration, Premium Users
Posts: 13,943
- Configure your firewall to allow inbound tcp connections to port 9524 (on the server running the service)
- the dreamweaver DLL should be in the webroot\bin folder (never tried longhorn since it's in beta)
jwalters
#3 Posted : Tuesday, December 12, 2006 10:05:26 PM
Rank: Freeware user

Groups: Member
Posts: 7
I've also tried installing Lansweeper on Windows Longhorn Server Build 5384. I had the same error as Tom who started this thread, but from what you said Smikkel I copied the Bin folder with its contents, DreamweaverCtrls.dll, into "C:\inetpub\wwwroot\". There was no Bin folder in wwwroot as my error was looking for DreamweaverCtrls there. This is on an isolated test domain, therefore it has no firewall installed and the default Windows one is disabled. The SQL Server is also on the same computer that the Lansweeper installation is on. The user, lsuser, has full access to SQL and can login when I connect to SQL via the Microsoft SQL Server Management Studio. The database is set for using SQL Server and Windows Authentication. The lsservice is running as a service and is started properly. Lsuser has been made a domain admin with local admin to ensure the user has no problems accessing anything. "Everybody" has been given full control over inetpub and lansweeper (folder on C:\ where the lansweeper files are located).

After doing the above I now get the following error:

Code:
System.Data.SqlClient.SqlException: An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
at System.Data.SqlClient.SqlConnection.Open()
at DreamweaverCtrls.DataSet.DoInit()
--------------------------------------------------------------------------------
System.Data.SqlClient.SqlException: An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
at System.Data.SqlClient.SqlConnection.Open()
at DreamweaverCtrls.DataSet.DoInit()
--------------------------------------------------------------------------------
System.Exception: The DefaultView was requested but no tables yet exist.
at DreamweaverCtrls.DataSet.get_DefaultView()
--------------------------------------------------------------------------------
System.Data.SqlClient.SqlException: An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
at System.Data.SqlClient.SqlConnection.Open()
at DreamweaverCtrls.DataSet.DoInit()
--------------------------------------------------------------------------------
System.Exception: The DefaultView was requested but no tables yet exist.
at DreamweaverCtrls.DataSet.get_DefaultView()


My LSservice.exe.config file looks like:
Code:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <appSettings>
        <!--   User application and configured property settings go here.-->
        <!--   Example: <add key="settingName" value="settingValue"/> -->
        <add key="ConnectionString" value="integrated security=SSPI;data source=lansweeper;;persist security info=False;initial catalog=lansweeper" />
        <add key="ConcurrentThreads" value="10" />
    </appSettings>
</configuration>


My web.config file:
Code:
<configuration>
    <appSettings>
        <add key="MM_CONNECTION_HANDLER_Lansweeper" value="sqlserver.htm" />
        <add key="MM_CONNECTION_STRING_Lansweeper" value="Persist Security Info=False;Data Source=localhost;Initial Catalog=Lansweeper;User ID=lsuser;Password=Password1" />
        <add key="MM_CONNECTION_DATABASETYPE_Lansweeper" value="SQLServer" />
        <add key="MM_CONNECTION_SCHEMA_Lansweeper" value="" />
        <add key="MM_CONNECTION_CATALOG_Lansweeper" value="" />
    </appSettings>
</configuration>


I've looked around to try to figure out what kind of default settings that SQL Server has for remote connections to see if anything fits, but I've found nothing so far. Any help would be appreciated.

Tom, how far along have you gotten?
Lansweeper
#4 Posted : Wednesday, December 13, 2006 9:40:49 AM

Rank: Administration

Groups: Administration, Premium Users
Posts: 13,943
So there are 3 problems

-lsclient cannot connect to server
(most likely cause server is firewalled, try telnetting to port 9524)
Tom do you also have this problem?

-Dreamweaver problem
Can't test it, since I don't have longhorn :)
Use filemon from sysinternals and check where the webserver tries to find the dreamweaver dll, copy the file there.
(or maybe it's a new feature in IIS7)

- Sql server problem.
Open SQL server configuration manager (from the start menu)
under network configuration, enable the protocols.
(this should solve the problem)

Doe you guys know if longhorn runs in vmware esx?
if so I will search a beta and test it myself.
insflavio
#5 Posted : Wednesday, January 10, 2007 6:02:02 PM
Rank: Freeware user

Groups: Member
Posts: 1
Location: BR
Hello !!

I have the same problem that Mr. JWalters, but i'm using SQL Server 2005 Express version with a Windows 2000 Advanced Server.

SMIKKEL, so i have 3 problems also ?

The worst is my SQL with all protocols enabled (TCP/IP and Named Pipes) and with SQL and Windows auth. I havn't restarted the server after these changes but the services (Lansweeper and sql services) were restarted more than once but the error message is the same.

Mr. JWalters, did you solve your problem ?

Thanks !
jwalters
#6 Posted : Friday, January 19, 2007 10:43:45 PM
Rank: Freeware user

Groups: Member
Posts: 7
No, I've not solved the problem I had. I've been too busy with other things to tackle this side project.
Users browsing this topic
Guest
Untag as favorite
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.